Sublime使用代理更新PackageControl

被墙

1
2
3
4
5
Package Control

There are no packages available for installation

Please see https://packagecontrol.io/docs/troubleshooting for help

恩 这年头 不会点科学上网连个Sublime插件都更新不下来 唉

挖洞

首先挖掘机试SS,不支持Http代理. 所以要先安装polipo将socket5的转成http

安装Polipo

1
brew install polipo

设置socket5转http

查看自己SS的监听端口

然后命令行执行

1
polipo socksParentProxy=localhost:1086

我的端口是1086,这块要换成你自己的

运行成功后出现

1
Established listening socket on port 8123.

设置Sublime的PackageControl使用代理

按图进入Sublime PackageControl的 Settings-Users

添加

1
2
"http_proxy": "http://127.0.0.1:8123",
"https_proxy": "http://127.0.0.1:8123",

如图

恩 然后一切就大功告成了.

坚持原创技术分享,您的支持将鼓励我继续创作!